You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

package.json 1.3KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. {
  2. "name": "easymde",
  3. "version": "2.6.0",
  4. "description": "A simple, beautiful, and embeddable JavaScript Markdown editor that easy to use. Features include autosaving and spell checking.",
  5. "files": [
  6. "dist/**/*",
  7. "src/**/*",
  8. "types/easymde.d.ts"
  9. ],
  10. "keywords": [
  11. "embeddable",
  12. "markdown",
  13. "editor",
  14. "javascript",
  15. "fontawesome"
  16. ],
  17. "main": "src/js/easymde.js",
  18. "types": "types/easymde.d.ts",
  19. "license": "MIT",
  20. "author": "Jeroen Akkerman",
  21. "dependencies": {
  22. "codemirror": "^5.43.0",
  23. "codemirror-spell-checker": "1.1.2",
  24. "marked": "^0.6.2"
  25. },
  26. "devDependencies": {
  27. "@types/codemirror": "0.0.72",
  28. "browserify": "^16.2.3",
  29. "gulp": "^4.0.0",
  30. "gulp-clean-css": "^4.0.0",
  31. "gulp-concat": "^2.6.1",
  32. "gulp-eslint": "^5.0.0",
  33. "gulp-header": "^2.0.7",
  34. "gulp-rename": "^1.4.0",
  35. "gulp-uglify": "^3.0.1",
  36. "typescript": "^3.3.3",
  37. "vinyl-buffer": "^1.0.0",
  38. "vinyl-source-stream": "^2.0.0"
  39. },
  40. "repository": "github:Ionaru/easy-markdown-editor",
  41. "scripts": {
  42. "prepare": "gulp",
  43. "test:types": "tsc --project types/tsconfig.json"
  44. }
  45. }